Earlier today, a small subset of XTruLink clients experienced brief, intermittent network disruptions, including occasional Cloudflare-related errors. Impact was limited and sessions typically restored within a few seconds.
We are now seeing full stability return across our network.
Our team will continue to monitor performance closely to ensure the issue is fully resolved.
Thank you for your patience.
Posted Feb 26, 2026 - 18:39 CST
Investigating
We are currently investigating reports of intermittent network instability affecting a small subset of XTruLink clients.
Our engineering team is actively working alongside our cloud infrastructure provider to identify the root cause and implement corrective measures. At this time, impact appears limited and core services remain operational.
We will continue to monitor closely and provide updates as more information becomes available.
Posted Feb 26, 2026 - 17:52 CST
This incident affected: XTruLink (XTruLink Cloud) and SwipeTrack.com (SwipeTrack.com).