Blackbaud BBMS BBIP payment outage

Incident Report for SwipeTrack Solutions

Resolved

Blackbaud has restored all payment connections and payments have been processing as expected over the last hour. We will continue to monitor systems for any issues. This Blackbaud issue is marked as resolved.
Posted Aug 04, 2026 - 10:13 CDT

Monitoring

Improvements continue to be observed with Blackbaud Payment service's connections. Organizations should see payments processing properly. We will continue monitoring Blackbaud's progress toward full resolution.
Posted Aug 04, 2026 - 09:09 CDT

Update

We are beginning to see improvements in the ability for our systems to sync with Blackbaud Payment services. We see online orders processing for a subset of clients. We will continue to monitor the progress of Blackbaud's resolution of their connection issue.
Posted Aug 04, 2026 - 08:40 CDT

Update

We are continuing to monitor the Blackbaud ID outage affecting payment processing. This outage may also affect the ability for our systems to sync with Altru, as API connections are affected by their outage. This may affect updates you make on membership or ticketing programs until the issue is resolved by Blackbaud.

You may choose to monitor Blackbaud's status page at status.blackbaud.com

XTruLink clients may use their handheld MPOS devices enabled with Stripe payment services to handle walk up admissions.
Posted Aug 04, 2026 - 08:19 CDT

Investigating

We are aware of an issue with Blackbaud Payment services that is affecting payments to online portals. We are monitoring this issue for a resolution from Blackbaud. Organizations with walk up patrons may utilize XTruLink MPOS devices enabled with Stripe merchant services to complete transactions.
Posted Aug 04, 2026 - 07:59 CDT
This incident affected: Blackbaud Connections (Altru Connection, BBMS / BBIP Connection (Payments)).